1076 Forwards on Weibo (30)

发布于:2025-04-08 ⋅ 阅读:(44) ⋅ 点赞:(0)

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID's for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can trigger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5

题目大意:有N个用户,每个用户关注了M个人。当一个人发布微博时,他的粉丝都会进行转发,但限定转发树的深度最大为L。现在给出K次查询,以及最多转发层数L,问每次查询时,对应id发布微博会有多少人转发。
分析:用带层数的广度优先遍历这个图。注意如果不额外使用变量标记深度时,需要等这一层的所有节点都被遍历过,才能增加深度。

#include<algorithm>
#include <iostream>
#include  <cstdlib>
#include  <cstring>
#include   <string>
#include   <vector>
#include   <cstdio>
#include    <queue>
#include    <stack>
#include    <ctime>
#include    <cmath>
#include      <map>
#include      <set>
#define INF 0xffffffff
#define db1(x) cout<<#x<<"="<<(x)<<endl
#define db2(x,y) cout<<#x<<"="<<(x)<<", "<<#y<<"="<<(y)<<endl
#define db3(x,y,z) cout<<#x<<"="<<(x)<<", "<<#y<<"="<<(y)<<", "<<#z<<"="<<(z)<<endl
#define db4(x,y,z,r) cout<<#x<<"="<<(x)<<", "<<#y<<"="<<(y)<<", "<<#z<<"="<<(z)<<", "<<#r<<"="<<(r)<<endl
#define db5(x,y,z,r,w) cout<<#x<<"="<<(x)<<", "<<#y<<"="<<(y)<<", "<<#z<<"="<<(z)<<", "<<#r<<"="<<(r)<<", "<<#w<<"="<<(w)<<endl
using namespace std;

int main(void)
{
    #ifdef test
    freopen("in.txt","r",stdin);
//    freopen("out.txt","w",stdout);
    clock_t start=clock();
    #endif //test

    int n,l;scanf("%d%d",&n,&l);
    vector<int>maps[n+5];
    for(int i=1;i<=n;++i)
    {
        int len;scanf("%d",&len);
        for(int j=1;j<=len;++j)
        {
            int a;scanf("%d",&a);
            maps[a].push_back(i);
        }
    }
    int k;scanf("%d",&k);
    for(int i=0;i<k;++i)
    {
        int query,ans=0;scanf("%d",&query);
        int flag[n+5]={0};flag[query]=1;
        queue<int>que;que.push(query);
        queue<int>level;level.push(0);
        while(!que.empty()&&level.front()<l)
        {
            int temp=que.front();que.pop();
            int depth=level.front();level.pop();depth++;
            for(int j=0;j<maps[temp].size();++j)
            {
                if(!flag[maps[temp][j]])
                {
                    que.push(maps[temp][j]),ans++,level.push(depth);
                    flag[maps[temp][j]]=1;
                }
            }
        }
        printf("%d\n",ans);
    }

    #ifdef test
    clockid_t end=clock();
    double endtime=(double)(end-start)/CLOCKS_PER_SEC;
    printf("\n\n\n\n\n");
    cout<<"Total time:"<<endtime<<"s"<<endl;        //s为单位
    cout<<"Total time:"<<endtime*1000<<"ms"<<endl;    //ms为单位
    #endif //test
    return 0;
}